NeoGriever

[BSNova] Burning Series Nova - Das Mega-Tool für BS.TO

1,349 posts in this topic

[align=center]Angefangen hat es mit dem Burning Series Serienfinder.

Ein rudimentäres kleines Tool mit einfachen Grundfunktionen.

Nach und Nach entwickelte sich daraus der Burning Series Master,

welcher auch BSM genannt wurde.

Mehr Funktionen und bessere Benutzbarkeit

sowie Benutzerfreundlichkeit.

Hilfreiche Funktionen und Tools

erleichterten das Schauen von Serien von bs.to.

Inzwischen hat sich das Tool weiterentwickelt und nennt sich

~{ BS Nova }~

Aktuelle Downloads und neue Informationen stets in der

Signatur von NeoGriever und in den neuesten Posts dieses Threads.

ToDo-Liste

Hier könnt ihr eure Ideen und Wünsche

eintragen und vorschlagen. Auch Bugs und

gewünschte Fixes können dort eingetragen werden.

Man erhält außerdem einen Überblick über aktuelle

Arbeiten und bereits fertige oder gar abgelehnte

Änderungswünsche/Fixes und Co.

Download-Bereich (Alle Versionen)

Hier könnt ihr die BSNova-Versionen von der ersten Beta-Version

bis zur aktuellsten Version herunterladen.

Beachtet bitte, dass ältere Versionen unter Umständen

nicht funktionieren.

Eine Spende an NeoGriever leisten

Da es ein Hobbyprojekt ist und ich damit weder Einnahmen, noch Profit mache,

biete ich die Möglichkeit, mir für meine Arbeit in Form von Spenden zu danken.

Es handelt sich hierbei nicht um Bettelei oder "Ich mach das für Spenden", sondern

um eine optionale Möglichkeit, Dank auszudrücken.

Wer spenden möchte, kann dies gerne tun. Es ist jedoch keine

Pflicht und zieht auch keine Bösen blicke mit sich, wenn man

die Spendenfunktion ignoriert.

[/align]

2 people like this

Share this post


Link to post
Share on other sites

Voila. Erste Release-Version.

BSNova v1

Es kann weiterhin zu Fehlern kommen. Jedoch läuft diese Version inzwischen so stabil, dass es als Release-Version durchgeht. Auch die Download-Ordner-Funktion sowie dessen Nutzung ist jetzt fehlerfrei.

Außerdem dürfte der BSNova nun keine Admin-Berechtigungen mehr benötigen. Die Anwendungsdaten (Cache, Logs und Konfigurationsdatei) sind unter %appdata% zu finden. Hat man keinen Download-Pfad eingestellt, wird der Eigene Videos Ordner als Ziel standardmäßig genutzt.

Share this post


Link to post
Share on other sites

Nur vor dem Installieren nach dem installieren kommt die Meldung nicht mehr.

Das kannst du einfach ignorieren wird wohl ein Fehlalarm sein.

Share this post


Link to post
Share on other sites

Kommt wahrscheinlich von InnoSetup. Ich kann derzeit kein MSI umsetzen, da dies ein registriertes Windows benötigt *abduck*

Share this post


Link to post
Share on other sites
da dies ein registriertes Windows benötigt *abduck*

Da duck ich mich mal auch mit ab. :D

Bei StreamCloud kannste auch auf 5 Sekunden packen, macht keinen unterschied. Bei download2 brauchst du zwar kein Sleep, da dies eigentlich nur nötig ist wenn du die "op" auch ausparst (download1)..

Gruß

Share this post


Link to post
Share on other sites
. Microsoft hat sich dieses System seit Vista / 7 / 8 ja nicht nur aus Langeweile oder aals Verkaufsargument ausgedacht
XP > Vista > 7 > 8 ... Ja. Wie gesagt. Es gibt da "Probleme zwischen XP und höheren Versionen", die ich so nicht einfach lösen kann.

Wie gesagt: nutze die Macht (der Umgebungsvariablen) ;)

Share this post


Link to post
Share on other sites

Kannst du eventuell die Version immer auf Dropbox hochladen, im ersten Post verlinken und aktuell halten? Wäre vlt. einfacher für alle, oder gibts schon einen Auto-Updater?

Share this post


Link to post
Share on other sites

Avira ist bei mir auch gleich angeschlagen aber wirklich nur beim installer danach ist ruhe im karton. Nach der Installation habe ich Avira wieder aktiviert und hab keine Meldung mehr bekommen.

@Scarwolf warum brauchst denn den installer noch auf dropbox der Link von Neo laeuft doch ?

Zum registrierten Windows sag ich mal auch nichts ausser meins laeuft und laeuft und laeuft und die updates gehen rein ohne probs und mein Windows meckert nicht wegen Zwangsaktivierung oder das etwas nicht in Ordnung waere selbst der genium check laeuft duch :D

Share this post


Link to post
Share on other sites

1. Einen Updater gibts nicht.

2. Dropbox ist bei mir nicht lauffähig. Kriege die Seite mit 5 kb/s nicht geöffnet.

3. Das mit Avira ist mir ein Mysterium. *kopfkratz*

Die Macht von Umgebungsvariablen nun ich nutze. ^^

Share this post


Link to post
Share on other sites

Hoppla, da ist wohl was schief gegeangen:

BSNova 1.0: Fehler beim Laden der Serienliste. Bitte starten sie den BSNova neu oder wenden Sie sich an den Progammierer.

Login funktioniert auch nicht mehr.

Beides weder nach mehrfachem Neustart, noch nach Start als Administrator. :(

Edit: Ich benutze eine "saubere" Installation von Windows 8.0 und Avast, der sich bei der Installation aber nicht gemeldet hat.

Verzeichnisse User\AppData\Roaming\BSNova, User\AppData\Roaming\BSNova\Cache und User\AppData\Roaming\BSNova\logfiles sind angelegt. Cache und logfiles sind leer, configurations.xml existiert.

Share this post


Link to post
Share on other sites

Mach mal Avast aus nur zum test und schaue mal ob es dan geht. Wen nicht schau mal bitte ob du per Browser auch drauf kommt wen auch nicht bleibt dir erstmal nur warten :P

Falls doch schau mal in der Windows Firewall und gebe das Programm auch mal dort frei eventuell geht es dan.

Share this post


Link to post
Share on other sites
Mach mal Avast aus nur zum test und schaue mal ob es dan geht. Wen nicht schau mal bitte ob du per Browser auch drauf kommt wen auch nicht bleibt dir erstmal nur warten :P

Falls doch schau mal in der Windows Firewall und gebe das Programm auch mal dort frei eventuell geht es dan.

Yupp. Schon gemacht. Avast komplett deaktiviert. Keine Änderung.

Edit: Firewallfreigabe hat nichts gebracht, auch komplette Deinstallation und Neuinstallation mit deaktiviertem Avast nicht.

Share this post


Link to post
Share on other sites

Yupp. Habe alles, was an Einstellungen geht, an und aus gestestet, immer mit dem gleichen Ergebnis.

Edit: So, Ok, gerade nochmal die 0.5.1 getestet, da geht alles einwandfrei. Seltsam ist, dass bei 1.0 nich mal ein Logfile angelegt wir.

Share this post


Link to post
Share on other sites

Hallo Zusammen

NeoGriever Saubere Arbeit.

Installation Problemlos.

Autologin Funktioniert

Serien auswählen und downloaden Funktioniert

Pfad Einstellung und download dort hin ist jetzt auch super. Funktioniert

Fertige Downloads gehen immer noch ins Nirvana und nicht ins abgeschlossene Downloads.

Instlation und ausführung gehen bei meinem Windows 7 Utlimate und Avast ohne Probleme sogar Amisoft anti Malware behindert nicht. Alles paletti

Kurzum fast null problemo bei der Ausführung.

Gratuliere Dir für den tollen Wurf, den Du da alleine auf die Beine Gestellt hast NeoGriever chapeau (Hut ab)

Nachtrag:

Habe soeben einen Absturz gehabt.

Als ich nach der Teststaffel von Die Strassen von San Francisco teilweise runter geladen hatte und noch

etwa 6 Episoden am laufen waren, hatte ich für den Download Staffel 2 bis 5 Bereitgestellt.

Danach verabschiedete sich BSN auf klassische weise.

Waren wohl gerade zuviele Anforderungen die das Programm bewältigen musst.

Tip: Erst weitere Staffeln dazu fügen, wenn die ausgewählte Staffel sichtbar für den Download bereit steht.

Liebe Grüsse

Cedric

Share this post


Link to post
Share on other sites

Hallo NeoGriever, ich habe mal die Version 1.0 mit dem Prozessmonitor laufen lassen und die Warnungen und Fehler bei Zugriffen auf Dateien und Registry unter Windows 8 protokolliert.

Wenn du die Datei haben möchtest, schreib mir wie ich sie dir zukommen lassen kann.

L. G.

Share this post


Link to post
Share on other sites

hattest du die vorige Version ordentlich deinstalliert, bevor du die v1 installiert hast ?

btw, glückwunsch zur v1 und den vermutlich damit einhergehenden floidschen Augenringen, Neo ;)

Share this post


Link to post
Share on other sites

Ich habe keine Augenringe ... Das ist noch von der Letzten Weihnachtsfeier ... Da haben mir meine "Freunde" Augenringe auftattoowiert ...

O_O

Share this post


Link to post
Share on other sites
Rechtsklick > Als Administrator ausführen ... ?

Nur mal so als Beispiel ...

Wenn du mich meinst: ich bin nicht ganz so blöd, wie mein Profilbild vielleicht aussieht.

Ich hab wirklich ALLES, was irgend möglich ist, ausprobiert.

Mehrfach mal als User, mal als Admin installiert, voher immer alles denstalliert, als User UND Admin mit sämtlichem möglichen Einstellungen getestet, mit und ohne Avast, mit und ohne Firewall Freigabe.

Unter Win 8 immer dasselbe Ergebnis: Serienliste kann nicht geladen werden (auch wenn ich manuell den Cache der 0.5.1 in den Cache Ordner kopiere) und Login ist unmöglich. Es wird auch kein Logfile angelegt.

Und die 0.5.1 läuft problemlos. Muss also was mit den Veränderungen von 0.5.1 nach 1.0.0 zu tun haben.

Fängst du eventuell alle Fehler bei Zugriff aufs Dateisystem ab, ohne eine Meldung auszugeben?

L. G.

P.S.: Wenn ich die nötige Entwicklungsumgebung und den Quellcode hätte, würde ich es ja selbst in Odrnung bringen. Aber ich kann mich auch mit den Macken der Version 0.5.1 zufrieden geben. Hauptsache, es läuft. Wird aber sicher manchen Windows 8 Usern nicht gefallen, die gerne den BSNova benutzn würden. ;)

Share this post


Link to post
Share on other sites

Ich hab die 1.0 in einer virtuellen Maschine mit Win 7 zum Laufen gebracht. Da ist mir aufgefallen, dass die Genre-Sortierung völliges Chaos produziert. 12 Monkeys zum Beispiel landet in Mystery statt in SciFi...

Der Logfile Ordner bleibt übrigens auch unter Win 7 leer.

Share this post


Link to post
Share on other sites
Fängst du eventuell alle Fehler bei Zugriff aufs Dateisystem ab, ohne eine Meldung auszugeben?
Ich fange absolut garkeine Dateisystemfehler ab. wenn eine Datei in Benutzung ist, worauf der BSNova zugreifen will, wird dies gnadenlos mit einem Crash mit Fehlermeldung beantwortet.

Ich habe in der v1 grundlegend nur die Umgebungsvariablen geändert und so die daten ausgelagert ...

PS: Das mit den Genres ist etwas komplizierter. Evtl. wird das Feature wieder entfernt ...

Share this post


Link to post
Share on other sites
Ich fange absolut garkeine Dateisystemfehler ab. wenn eine Datei in Benutzung ist, worauf der BSNova zugreifen will, wird dies gnadenlos mit einem Crash mit Fehlermeldung beantwortet.

Ich habe in der v1 grundlegend nur die Umgebungsvariablen geändert und so die daten ausgelagert ...

Ok, das grenzt den Fehler ja schon etwas ein. Unter Win 7 läuft es ja auch einwandfrei, bis auf dass es da auch keinen Logfile gibt.

Der Fehler muss ja passieren, bevor die Statusmeldung mit dem Ladeproblem der Liste generiert wird.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now