Jump to content
chmee

Burning Series Addon für Kodi XBMC (classic)

Recommended Posts

vor 7 Stunden schrieb fepilins:

Ich habe in der main.py in der Funktion showVideo mal folgendes eingebaut:

print data['fullurl'].encode('utf8')

Im Log steht dann

09:31:21 T:18112   DEBUG: javascript:alert('Nicht möglich');

In der Funktion getURL habe ich ebenfalls mal eine Ausgabe eingebaut:

DEBUG: {"hoster":"OpenLoad","url":"gx0N-FaEibg\/Shameless.S06E03.Abgeraeumt.GERMAN.DUBBED.WS.HDTVRip.x264-TVP.mkv","part":"1","epi":"152037","fullurl":"javascript:alert('Nicht m\u00f6glich');"}

Das Problem ist also, dass die API die fullurl garnicht liefert... weiß jemand warum?

 

if 'openload' in data['hoster'].lower():
        videoLink = urlresolver.resolve('https://openload.co/embed/' + data['url'])
else:
        videoLink = urlresolver.resolve(data['fullurl'])

 

Share this post


Link to post
Share on other sites

Mit dem originalen Addon von Chmee Version 1.5.1.1 und dem Update 3.0.24 des URLResolver (via tvaddons.ag repo) funktioniert bei mir jetzt Vivo, Openload, OpenloadHD etc. . Nur FlashX läuft nicht aber die sollen angeblich den Code täglich ändern damit es nicht funktioniert. Also sehr gute Nachrichten :D

Share this post


Link to post
Share on other sites

Hat einer von Euch das zufällig auf einem Raspberry PI laufen.

Konfiguration ist ein PI B mit LibrELEC 17.
Ich hab das originale Addon von Chmee (version 1.5.1.1) drauf und den URL Resolver 3.0.24 (habe es vorher aber auch mit diversen anderen Resolvern, angefangen von 3.0.17 an, probiert)

Ich bekomme allerdings nur VIvo und vidto zum laufen.


Bei einigen anderen Hostern bekomme ich die Meldung das die Url nicht "umgesetzt" werden kann, oder so ähnlich.

Mit der vorherigen URLResolver version, welche ich verwendet habe. (3.0.21) waren es vidto und FlashX.

Muss ich noch irgendwas zusätzlich machen, damit ich die Streams von Openload zum laufen bekomme. Ich bekomme immer Fehlermeldungen, mit denen ich leider (mangels Wissen) nichts anfangen kann.

 

LG

Share this post


Link to post
Share on other sites

Ich hab auch Libreelec Kodi Jarvis am pi3 und die addon version 1.5.1.1 . URL Resolver weiss ich nicht, da musste ich nie was umstellen. Bei mir geht bis auf die Suche alles einwandfrei nachdem ich API vollenden gedrückt habe. 

Bei Openload-Links kommt die Meldung, dass man sich authentifizieren soll (pair), wenn man das macht gehts ohne probleme.

Share this post


Link to post
Share on other sites
vor 31 Minuten schrieb vozer:

Ich hab auch Libreelec Kodi Jarvis am pi3 und die addon version 1.5.1.1 . URL Resolver weiss ich nicht, da musste ich nie was umstellen. Bei mir geht bis auf die Suche alles einwandfrei nachdem ich API vollenden gedrückt habe. 

Bei Openload-Links kommt die Meldung, dass man sich authentifizieren soll (pair), wenn man das macht gehts ohne probleme.

API vollenden ist ja schon Standard, das hab ich ja gemacht . Ist nicht mein erster PI. Ich hab schon FireTV Sticks und andere Boxen für Freunde aufgesetzt. :)

Kannst Du mir bitte verraten, wie ich das mit dem authentifizieren machen muss? Muss ich mir da bei Openload einen Account erstellen? Und den irgendwo hinterlegen?


Vielen Dank!

Liebe Grüße


 

 

 

Share this post


Link to post
Share on other sites

BS lässt sich nicht mehr auf Libreelec starten.

folgende Fehlermeldung bekomme ich:

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--

                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!

                                            Error Type: <type 'exceptions.TypeError'>

                                            Error Contents: string indices must be integers

                                            Traceback (most recent call last):

                                              File "/storage/.kodi/addons/plugin.video.burningseries/main.py", line 418, in <module>

                                                ok = showContent(sortType)

                                              File "/storage/.kodi/addons/plugin.video.burningseries/main.py", line 80, in showContent

                                                serie = [""+d['series'].strip()+"",d['series'],d['id']]

                                            TypeError: string indices must be integers

                                            -->End of Python script error report<--

 

Kann mir jemand sagen, was ich jetzt machen kann?

Share this post


Link to post
Share on other sites

@Krustyx: Welche Version von LibreELEC (Kodi) benutzt Du? Auf welchem Device? API-Vollenden gemacht?

Keine Probleme mit Wetek Play/LibreELEC mit Kodi 16.1 und dem orginalen BS-Addon.

Share this post


Link to post
Share on other sites

Hey. Hab heute versucht Burning Serie auf dem Fire TV Stick zum laufen zu bekommen. Erst via App und jetzt via Kodi.

Api Vollendet und auch den URLResolver installiert.

Openload/pair gemacht und jetzt versucht der das Video zu starten aber bringt dann ab.

Hab ich noch was vergessen?

Gruß Tobias

Share this post


Link to post
Share on other sites
vor 56 Minuten schrieb Jack Bauer:

Also bei mir Funktioniert es definitiv nicht mehr. 

Dann machst du vermutlich etwas falsch. :)

Gerade eben habe ich es noch einmal probiert und es funktioniert einwandfrei, inklusive openload (sonst nutze ich meist xStream). 

Mein Setup:  FireTV Stick, Kodi 16.1 (2016-04-24), URL Resolver 3.0.27 von tvaddons.ag. 

 

Share this post


Link to post
Share on other sites
vor 15 Minuten schrieb spejbl:

Dann machst du vermutlich etwas falsch. :)

Gerade eben habe ich es noch einmal probiert und es funktioniert einwandfrei, inklusive openload (sonst nutze ich meist xStream). 

Mein Setup:  FireTV Stick, Kodi 16.1 (2016-04-24), URL Resolver 3.0.27 von tvaddons.ag. 

 

Da sich der Beitrag nicht bearbeiten lässt: Ich habe eben noch das Update auf Kodi 17 gemacht, und auch da läuft (scheinbar) alles wunderbar.

Share this post


Link to post
Share on other sites

Moin, erstmal danke für das tolle Addon!?

Bei mir auf einem RPI 2 mit OSMC läuft es nach wie vor super. Würde nur gerne mal wissen wie das mit der "watched"-Funktion funktioniert?

Edited by John117
Grammatik

Share this post


Link to post
Share on other sites

Hallo Leute!

Leider funktionieren bei mir alle Hoster nicht mehr. Entweder kommt die Meldung ERROR Video deleted or url resolver cant handle host oder burningSeries Fehler fur mehr Logdatei einsehen.

Kann mir bitte jemand weiter helfen, ich bin Laie und habe kaum Ahnung. 

Setup: Sony Android 6, Kodi 16.1 und Kodi 17

Share this post


Link to post
Share on other sites

Also bei mir läuft es immer noch. Ich benutze die Version 1.5.1.1 und habe den URL-Revolver von tvaddons.ag (ist glaube ich die Version 3.0.28) installiert. Nur der watched-Status funktioniert bei mir nicht, was daran liegt das er die watched.data nicht füllt.

Share this post


Link to post
Share on other sites
vor 5 Stunden schrieb John117:

Also bei mir läuft es immer noch. Ich benutze die Version 1.5.1.1 und habe den URL-Revolver von tvaddons.ag (ist glaube ich die Version 3.0.28) installiert. Nur der watched-Status funktioniert bei mir nicht, was daran liegt das er die watched.data nicht füllt.

Also hast du den "mitgelieferten" URLResolver deinstalliert und manuell installert, also den von tvaddons?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×