Jump to content

throw

Member
  • Posts

    0
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

throw's Achievements

Newbie

Newbie (1/13)

0

Reputation

  1. Hi! Ich habe mich hier angemeldet, weil ich das selbe Problem wie c186046 auf meinem Raspberry Pi 2 mit retropie bzw. Debian Jessie hatte. Nach etwas rumprobieren habe ich herausgefunden, dass es bei mir zumindest daran lag, dass die SSL Verbindung nicht aufgebaut werden konnte. Bei python versionen vor 2.7.9 war das kein Problem, weil die Verbindung bei ungültigem SSL Zertifikat einfach trotzdem aufgebaut wurde. Ich weiß noch nicht genau, warum die SSL Verbindung scheitert (auf meinem anderen RPi2 mit Arch ARM und python 2.7.11 läuft alles), aber man kann das ganze, wenn man unbedingt will, umgehen. Dazu muss natürlich gesagt sein, dass es nicht unbedingt die beste Lösung ist die Verifizierung des SSL-Zertifikats auszuhebeln. In der Datei main.py im Addon Verzeichnis ($KODI_VERZEICHNIS/addons/plugin.video.burningseries/main.py) müssen die folgenden drei Zeilen am besten vor den Funktionsdefinitionen eingefügt werden. Bei mir ist das in Zeile 31. import ssl if hasattr(ssl, '_create_unverified_context'): ssl._create_default_https_context = ssl._create_unverified_context Das ist aber keine Dauerlösung. Ich update mal meinen RPi auf Debian Stretch (mit python 2.7.11) und melde mich nochmal, falls das Problem dadurch behoben wird. Das Update auf Debian Stretch mit python 2.7.11 hat das Problem tatsächlich behoben. Da aber noch mehr Dinge als nur Python geupdated wurden kann ich nicht sagen, ob es wirklich nur daran lag. Eventuell kann c186046 oder ein anderer Windows User mit dem Problem mal nachschauen, welche python Version installiert ist und ggf. updaten.
×
×
  • Create New...